Support Forum

I host my Joomla site on VPS under Ubuntu16.04/Apache2/Mysql5.7.25 and I use webmin/virtualmin to take care of the thick of server configurations. Recently I have been trying to install PHP 7.2, after I did it, all folders under "system information->folder permissions" became unwritable.
I check the folders' mod, they are either 644 or 755 as usual, and their owner is the same as before too. My apache2's user is "www-data", so for test's sake, I changed the owner of these folders to "www-data", now all the folders became "writable" again. But this is hardly a solution.
Did anyone encounter this too? What could have caused this problem?
Responses (3)
  • Accepted Answer

    Monday, February 11 2019, 06:21 AM - #Permalink
    I am digesting some other ways to overcome this issue, such as only changing the user group to www-data then modify file mods.... but the question is, why didn't I have to do this before I upgraded to PHP7.2? Is there something new in PHP7.2 that requires me to do this or it is just some server side misconfiguration?
    The reply is currently minimized Show
  • Accepted Answer

    Monday, February 11 2019, 08:02 AM - #Permalink
    OK, after several hours' toiling, I think I can better describe the problem now and I think the problem does have to do with my installation, I probably left some key module behind:

    On my Virtualmin I can choose to enable php modules(5.6,7.0,7.2), I've found out that if I enable 7.0 instead of 7.2, the problem will be no more. Whereas the PHP execution mode is FastCGI and its PHP version is 7.2, also fpa shows PHP version is 7.2.
    How apache's php module is working together with FastCGI is still in over my head. I've thought with PHP exe mode set to FastCGI, I could even disable apache's php module, but it turns out in my case I need to enable it and I need to enable it as PHP 7.0. It sounds very weird but it definitely works for me.

    But I am not satisfied with merely get it working. I want it to work with 7.2 module. To achieve this, I guess that I probably need to install some additional apache module for php7.2 to get the FastCGI work with apache's PHP7.2 module, but I can't find where to start with. Can anyone give any hint?
    The reply is currently minimized Show
  • Accepted Answer

    Monday, February 11 2019, 10:38 AM - #Permalink
    Hi Shengke,

    You need to work this out with your Hosting Support.
    Unfortunately, I don't have much knowledge about "Server Configuration and Administration", I'm a front-end developer. Therefore, I cannot help here at all.

    Also, as you already know, the issue you experience has nothing to do with our products.

    Hopefully, there will be another user here in the forum who will be able to help you.
    The reply is currently minimized Show
Your Reply

Become an insider | Subscribe to our Newsletter
Subscribe to our mailing list and stay up-to-date with all our awesome releases, latest updates and amazing discount offers!